I have CMSF and a module, patched to the latest version. Now I want to buy another module. Do I need to do anything special?

This is easier explained based on a couple of examples: - Let's say that you have CMSF and the Marines module, patched to version 1.21. Now you want to purchase the British Forces module (which was released as v1.20). If you simply install British Forces over your current game installation, you will effectively downgrade your game to v1.20. Therefore, after installing the module, make sure that you run the latest patch available AFTERWARDS. When you do so, make sure you select the correct components to update (in the above example, that would be selecting "Update CMSF + Marines + British"), and this will ensure that you have all components installed correctly and properly patched to the latest version. - Let's say you have CMSF and Marines and NATO, patched to version 1.31. Now you want to purchase the British Forces module (which is v1.20). If you simply install British Forces over your current game installation, you will effectively downgrade your game to v1.20. Here are the quickest steps to add British and retain your version: - don't uninstall anything - install British Forces (-> v1.20) - re-install v1.21 patch. Make sure to select CMSF, Marines and British as the components to update (-> v1.21) - re-install v1.31 patch. Make sure to select CMSF, Marines, British and NATO as the components to update (-> v1.31)